Support Forum

Flashing an EU Bike to US Version - Problems with Pinout and License

jan-erik.bohlen@ewetel.netjan-erik.bohlen@ewetel.net Posts: 2Verified User

Hey Guys, I tried flashing my 2013 636e (EU Model) to the US Version, so I could remove the Ignition Key etc. But after flashing the bike wouldn't run properly, didn't hold idle at all and missed a lot, so I guess the pinout for the EU Version is different from the US Version? Is there a possiblility that there is an option for "EU Harness" for the Kawa like in the R6 maps? Or could you tell me which pins I need to change in the harness to make the US version work? After that, I changed the flash back to the EU Version, but since then, the program sometimes drops error messages, that the ECU is not registered to my account. After restarting the program, it works again. Is there a way to fix that? Thanks in advance, Jan

Comments

  • todd@ftecu.comtodd@ftecu.com Posts: 85Staff User

    If one is being prompted for a license, it could be because:

    1. There is an intermittent connection in the bench or bike side program harness. (Check the wiring)
    2. After a confirmed write, at the end not physically disconnecting the ecu before attempting to write another file. (Disconnect ecu after each write/attempt.)
    3. Starting with the tuning cable and power connected to the ecu before starting to write and when prompted to connect or disconnect, just clicking ok and not physically doing that. (Please follow all prompts to ensure the ecu is put into program mode.)
    4. Writing a file that does not match the ecu pn can prompt for a license and toggling between the wrong and right file. (Ensure the files match the ecu pn.)
    5. The ecu is not the same one that was last flashed with the license. (Verify it is same ecu).

    These are just the most common issues why one is prompted for a license.

  • jan-erik.bohlen@ewetel.netjan-erik.bohlen@ewetel.net Posts: 2Verified User

    I think its Point 4, that's the problem. My ECU got the serial number 21175-0811(EU). I tried flashing the 21175-0810 (US) on it, to remove the immobilizer, but the bike wouldn't start after that. So I flashed the ECU back to 0811(EU), but since then, I'm getting the license errors. Is it possible to reset the license somehow to get rid of this failure?

Sign In or Register to comment.