Support Forum

Writing attempt failed. Failed patching image data.

wenxx10@gmail.comwenxx10@gmail.com Posts: 7Verified User

Hi,

I recently got the bench side kit for flashing the ecu of my EU Yamaha R7 2022. However, when I connect the ECU to the bench kit harness and try to write the 2021 R7 - BEB-8591A-50(EU) Unrestricted into the ECU, it complains that "Writing attempt failed. Failed patching image data."

As I observed, the actual part number on my ECU is BEB-8591A-00. Could it be related to the issue?

Thanks

Comments

  • wenxx10@gmail.comwenxx10@gmail.com Posts: 7Verified User

    As I saw from one of the most important posts, the ECU file must match the ECU part number. So I guess that answers the question.

    Though in this case, since I cannot find the proper fole in the provided list (and I could not have checked/known this before ordering), is there a way to request the file of my corresponding ECU part number to be added?

  • wenxx10@gmail.comwenxx10@gmail.com Posts: 7Verified User

    Any ideas?

  • mike@ftecu.commike@ftecu.com Posts: 178Staff User

    Hello,

    Have you got this sorted out? With the Yamaha ECU's you would have to send it to us to be read for the first time. Then it will be added to the File Manager for use.

  • wenxx10@gmail.comwenxx10@gmail.com Posts: 7Verified User

    I see that the file is actually added now, though as I tried again with the BEB-8591A-00 file, it still complains aobut the same error:


    Status: failed patching imagedata


    I followed the procedure where:


    1. Opened ftecu software
    2. Opened the unrestricted file for BEB-8591A-00
    3. Device -> Write ECU
    4. After pop-up about connecting the ECU harness, connected the desk harness USB and also the power
    5. Clicked OK on the pop-up
    6. Confirmation pop-up about assigning license to the ECU -> Yes
    7. Error message

    Can you please advise something further?

  • wenxx10@gmail.comwenxx10@gmail.com Posts: 7Verified User
    edited June 2023

    I actually managed to write the stock file to the ECU, but when I tried to adjust the files and flash (copying fuel and ignition maps except for volt-dwell), now it first complains about:


    Write attempt failed. Please tryagain.

    Status: undefined error


    Then if I try again, it says:


    No Registered ECU found.

    Would you like to purchase a new licesne for this ECU?


    Based on other threads, I assume this needs a reset? Could you please have a check?

  • staffan.ola.wallin@gmail.comstaffan.ola.wallin@gmail.com Posts: 2Verified User

    I have the exact same issue. I was able to write the BEB-8591A-00 stock ECU.

    but now when i try write same but unrestricted file it says that it wont write bla.bla.bla.

    i bought another licenses but that didnt help either.

    my account is Staffan.ola.wallin@gmail.com

    plz fix this now.

Sign In or Register to comment.