Support Forum

If your Tuning Suite software is stalled on "Loading..."

kento_ftecukento_ftecu Posts: 776Staff User

We have found there are some users with an issue occurring when they first try to download/open the FTECU Tuning Suite software, or haven't opened the software in months. The software stalls on the "Loading" progress bar and doesn't change. If you run into this issue, the solution is to insert your USB Data Link cable into your computer (just the cable, it doesn't need to be attached to a flash harness), and open the software. It may take a few seconds, but you should eventually see the login window appear.


  • Posts: 12Verified User

    Hi, i have this problem and i connect usb data link cable but still stays in Loading (2 laptops same problem). I see in control panel the device (USB serial converter) but didn't open. Can someone check if is my account problem . Thanks

  • Posts: 7Verified User

    Hey everyone,

    haven’t opened the tuner suite in quite some time. First time opening it was stuck on the loading screen. Deleted the app then downloaded latest version, restart the pc and same thing stuck on the loading screen. Stumbled upon this thread and I tried what kento suggested inserted the data link usb cable and waited but yet nothing happened. Dimbusa did you find a fix to your similar situation? My license is confirmed and all I’m trying to do is add the blip kit to my bike.

  • Posts: 1,071Staff User


    Does your computer recognize your USB cable as a "USB Serial Converter" under the device manager or does it show like an unidentified device?


    Jason A.

  • Posts: 1Verified User

    I plugged the data cable in started the software and it worked.

  • Posts: 1Verified User

    I can't seem to get my software to recognize the USB cable.

  • Posts: 1Verified User

    The same problem does not recognize the ecu, an error is written, I don’t know what to do, I checked everything several times!

  • Posts: 3FTECU Dealer


    Have you tried starting the software and logging in before you plug the USB cable in?

  • Posts: 178Staff User
Sign In or Register to comment.